use strict;
my $str = 'I don\'t know \'how\' to remove these \' things';
my $regex = qr/\b'\b(*SKIP)(*F)|'/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";