#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!^|\n|[.!?] )[A-Z\d][A-Za-z\d]*(?: (?:of )?[A-Z\d][A-Za-z\d]*)*"
Local $sString = "My name is Sam Helsen or Sam H Helsen son of M Helsen working at 3M technologies as the President of Sales." & @CRLF & _
"The first word in a sentence won't match. A capitalized word followed by "of" and another capitalized word will be matched: Foo of Bar. Not if the 2nd word is lowercase though: Foo of bar." & @CRLF & _
"Words starting with digits will be matched even if not capitalized: 123foo."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")