# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!^|\n|[.!?] )[A-Z\d][A-Za-z\d]*(?: (?:of )?[A-Z\d][A-Za-z\d]*)*"
test_str = ("My name is Sam Helsen or Sam H Helsen son of M Helsen working at 3M technologies as the President of Sales.\n"
"The first word in a sentence won't match. A capitalized word followed by \"of\" and another capitalized word will be matched: Foo of Bar. Not if the 2nd word is lowercase though: Foo of bar.\n"
"Words starting with digits will be matched even if not capitalized: 123foo.")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.