re = /(?<!^|\n|[.!?] )[A-Z\d][A-Za-z\d]*(?: (?:of )?[A-Z\d][A-Za-z\d]*)*/
str = 'My name is Sam Helsen or Sam H Helsen son of M Helsen working at 3M technologies as the President of Sales.
The first word in a sentence won\'t match. A capitalized word followed by "of" and another capitalized word will be matched: Foo of Bar. Not if the 2nd word is lowercase though: Foo of bar.
Words starting with digits will be matched even if not capitalized: 123foo.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end