import Foundation
let pattern = #"(?<!^|\n|[.!?] )[A-Z\d][A-Za-z\d]*(?: (?:of )?[A-Z\d][A-Za-z\d]*)*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
My name is Sam Helsen or Sam H Helsen son of M Helsen working at 3M technologies as the President of Sales.
The first word in a sentence won't match. A capitalized word followed by "of" and another capitalized word will be matched: Foo of Bar. Not if the 2nd word is lowercase though: Foo of bar.
Words starting with digits will be matched even if not capitalized: 123foo.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)