$re = '/(?<!^|\n|[.!?] )[A-Z\d][A-Za-z\d]*(?: (?:of )?[A-Z\d][A-Za-z\d]*)*/';
$str = 'My name is Sam Helsen or Sam H Helsen son of M Helsen working at 3M technologies as the President of Sales.
The first word in a sentence won\'t match. A capitalized word followed by "of" and another capitalized word will be matched: Foo of Bar. Not if the 2nd word is lowercase though: Foo of bar.
Words starting with digits will be matched even if not capitalized: 123foo.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);