const regex = new RegExp('(?<!^|\\n|[.!?] )[A-Z\\d][A-Za-z\\d]*(?: (?:of )?[A-Z\\d][A-Za-z\\d]*)*', 'g')
const str = `My name is Sam Helsen or Sam H Helsen son of M Helsen working at 3M technologies as the President of Sales.
The first word in a sentence won't match. A capitalized word followed by "of" and another capitalized word will be matched: Foo of Bar. Not if the 2nd word is lowercase though: Foo of bar.
Words starting with digits will be matched even if not capitalized: 123foo.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}