#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:[^a-zA-Z0-9]*[a-zA-Z0-9]){3}"
Local $sString = "+++++' 'asd'''''''''''sdsdsdsdsdsddddddddddddddddddddddddddddddddd'''' fdfdfdfdfddfdfdfdfdfdfdfdfdfdfdfdf''sssdssssssssssssssssssssssssss'''''sd''''''' d" & @CRLF & _
"'''''''''''''sd'' sfdasdasd dsa sdk' d' ddaf 3f0 sc'ddd'_0_c_8_'' 9 9d 'c'ddd'_0_csdf" & @CRLF & _
"as 0a" & @CRLF & _
"_0_c_sdf8_" & @CRLF & _
"K9Jk0-asd" & @CRLF & _
"L________f______________3j" & @CRLF & _
"]\[][]\["
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")