import re
regex = re.compile(r"(?:[^a-zA-Z0-9]*[a-zA-Z0-9]){3}")
test_str = ("+++++' 'asd'''''''''''sdsdsdsdsdsddddddddddddddddddddddddddddddddd'''' fdfdfdfdfddfdfdfdfdfdfdfdfdfdfdfdf''sssdssssssssssssssssssssssssss'''''sd''''''' d\n"
"'''''''''''''sd'' sfdasdasd dsa sdk' d' ddaf 3f0 sc'ddd'_0_c_8_'' 9 9d 'c'ddd'_0_csdf\n"
"as 0a\n"
"_0_c_sdf8_\n"
"K9Jk0-asd\n"
"L________f______________3j\n"
"]\\[][]\\[")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")