const regex = /(?:[^a-zA-Z0-9]*[a-zA-Z0-9]){3}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[^a-zA-Z0-9]*[a-zA-Z0-9]){3}', '')
const str = `+++++' 'asd'''''''''''sdsdsdsdsdsddddddddddddddddddddddddddddddddd'''' fdfdfdfdfddfdfdfdfdfdfdfdfdfdfdfdf''sssdssssssssssssssssssssssssss'''''sd''''''' d
'''''''''''''sd'' sfdasdasd dsa sdk' d' ddaf 3f0 sc'ddd'_0_c_8_'' 9 9d 'c'ddd'_0_csdf
as 0a
_0_c_sdf8_
K9Jk0-asd
L________f______________3j
]\\[][]\\[`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}