re = /(?:[^a-zA-Z0-9]*[a-zA-Z0-9]){3}/
str = '+++++\' \'asd\'\'\'\'\'\'\'\'\'\'\'sdsdsdsdsdsddddddddddddddddddddddddddddddddd\'\'\'\' fdfdfdfdfddfdfdfdfdfdfdfdfdfdfdfdf\'\'sssdssssssssssssssssssssssssss\'\'\'\'\'sd\'\'\'\'\'\'\' d
\'\'\'\'\'\'\'\'\'\'\'\'\'sd\'\' sfdasdasd dsa sdk\' d\' ddaf 3f0 sc\'ddd\'_0_c_8_\'\' 9 9d \'c\'ddd\'_0_csdf
as 0a
_0_c_sdf8_
K9Jk0-asd
L________f______________3j
]\\[][]\\['
# Print the match result
str.match(re) do |match|
puts match.to_s
end