using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:.+\\*)([0-9]{8})(?:.+)(?:\.)(?:.+)$";
string input = @"""C:\\Users\\username\\C-Sharp\\Project\\12345678_X\\Folder\\56781234_01.itm""";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}