import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:.+\\\\*)([0-9]{8})(?:.+)(?:\\.)(?:.+)$";
final String string = "\"C:\\\\Users\\\\username\\\\C-Sharp\\\\Project\\\\12345678_X\\\\Folder\\\\56781234_01.itm\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}