$re = '/^(?:.+\\\\*)([0-9]{8})(?:.+)(?:\.)(?:.+)$/';
$str = '"C:\\\\Users\\\\username\\\\C-Sharp\\\\Project\\\\12345678_X\\\\Folder\\\\56781234_01.itm"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);