package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:.+\\*)([0-9]{8})(?:.+)(?:\.)(?:.+)$`)
var str = `"C:\\Users\\username\\C-Sharp\\Project\\12345678_X\\Folder\\56781234_01.itm"`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}