re = /^(?:.+\\*)([0-9]{8})(?:.+)(?:\.)(?:.+)$/
str = '"C:\\\\Users\\\\username\\\\C-Sharp\\\\Project\\\\12345678_X\\\\Folder\\\\56781234_01.itm"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end