#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\w+)(?:\.(\d+))?(?:\.(\d+))?(?:([a-z]+))?"
Local $sString = "select all objects where [verse code='MAT' and chapter='1' and number = '1' GET code, chapter, number] go"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")