const regex = /(\w+)(?:\.(\d+))?(?:\.(\d+))?(?:([a-z]+))?/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+)(?:\\.(\\d+))?(?:\\.(\\d+))?(?:([a-z]+))?', '')
const str = `select all objects where [verse code='MAT' and chapter='1' and number = '1' GET code, chapter, number] go`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}