re = /(\w+)(?:\.(\d+))?(?:\.(\d+))?(?:([a-z]+))?/
str = 'select all objects where [verse code=\'MAT\' and chapter=\'1\' and number = \'1\' GET code, chapter, number] go'
# Print the match result
str.match(re) do |match|
puts match.to_s
end