package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w+)(?:\.(\d+))?(?:\.(\d+))?(?:([a-z]+))?`)
var str = `select all objects where [verse code='MAT' and chapter='1' and number = '1' GET code, chapter, number] go`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}