$re = '/(\w+)(?:\.(\d+))?(?:\.(\d+))?(?:([a-z]+))?/';
$str = 'select all objects where [verse code=\'MAT\' and chapter=\'1\' and number = \'1\' GET code, chapter, number] go';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);