import re
regex = re.compile(r"(\w+)(?:\.(\d+))?(?:\.(\d+))?(?:([a-z]+))?")
test_str = "select all objects where [verse code='MAT' and chapter='1' and number = '1' GET code, chapter, number] go"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")