# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([,?!])\1+\s*/$1 /g;t' <<< " Helloooooo my frieeend!!!What are you doing?? Tell me what you like...........,please. "