use strict;
my $str = ' Helloooooo my frieeend!!!What are you doing?? Tell me what you like...........,please. ';
my $regex = qr/([,?!])\1+\s*/p;
my $subst = '$1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";