using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([,?!])\1+\s*";
string substitution = @"$1 ";
string input = @" Helloooooo my frieeend!!!What are you doing?? Tell me what you like...........,please. ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}