const regex = /([,?!])\1+\s*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([,?!])\\1+\\s*', 'g')
const str = ` Helloooooo my frieeend!!!What are you doing?? Tell me what you like...........,please. `;
const subst = `$1 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);