re = /([,?!])\1+\s*/
str = ' Helloooooo my frieeend!!!What are you doing?? Tell me what you like...........,please. '
subst = '$1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result