#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([,?!])\1+\s*"
Local $sString = " Helloooooo my frieeend!!!What are you doing?? Tell me what you like...........,please. "
Local $sSubst = "$1 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)