$re = '/([,?!])\1+\s*/';
$str = ' Helloooooo my frieeend!!!What are you doing?? Tell me what you like...........,please. ';
$subst = "$1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;