#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<!-- Begin section -->(?s).*<!-- End section -->"
Local $sString = "<!-- Begin section -->Lots of code here<!-- End section -->" & @CRLF & _
"<!-- Begin section -->More code<!-- End section -->" & @CRLF & _
"<!-- Begin section -->Code spread out " & @CRLF & _
"over two lines<!-- End section -->"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")