package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<!-- Begin section -->(?s).*<!-- End section -->`)
var str = `<!-- Begin section -->Lots of code here<!-- End section -->
<!-- Begin section -->More code<!-- End section -->
<!-- Begin section -->Code spread out
over two lines<!-- End section -->`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}