using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<!-- Begin section -->(?s).*<!-- End section -->";
string input = @"<!-- Begin section -->Lots of code here<!-- End section -->
<!-- Begin section -->More code<!-- End section -->
<!-- Begin section -->Code spread out
over two lines<!-- End section -->";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}