const regex = /<!-- Begin section -->(?s).*<!-- End section -->/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<!-- Begin section -->(?s).*<!-- End section -->', '')
const str = `<!-- Begin section -->Lots of code here<!-- End section -->
<!-- Begin section -->More code<!-- End section -->
<!-- Begin section -->Code spread out
over two lines<!-- End section -->`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}