// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<!-- Begin section -->(?s).*<!-- End section -->").unwrap();
let string = "<!-- Begin section -->Lots of code here<!-- End section -->
<!-- Begin section -->More code<!-- End section -->
<!-- Begin section -->Code spread out
over two lines<!-- End section -->";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}