import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<!-- Begin section -->(?s).*<!-- End section -->";
final String string = "<!-- Begin section -->Lots of code here<!-- End section -->\n"
+ "<!-- Begin section -->More code<!-- End section -->\n"
+ "<!-- Begin section -->Code spread out \n"
+ "over two lines<!-- End section -->";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}