import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https:\\/\\/[a-z]{2,3}\\.linkedin\\.com\\/.*$";
final String string = "https://www.linkedin.com/sometext\n"
+ "https://uk.linkedin.com/in/wiliam-ferraciolli-a9a29795\n"
+ "https://it.linkedin.com/hp/\n"
+ "https://cy.linkedin.com/hp/\n"
+ "https://www.linkedin.com/profile/view?id=AAIAABQnNlYBIx8EtS5T1RTUbxHQt5Ww&trk=nav_responsive_tab_profile\n\n\n\n"
+ "http://stackoverflow.com/questions/ask\n"
+ "google.com\n"
+ "http://uk.linkedin.com/in/someDodgeAddress\n"
+ "http://dodge.linkedin.com/in/someDodgeAddress";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}