import Foundation
let pattern = #"^https:\/\/[a-z]{2,3}\.linkedin\.com\/.*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
https://www.linkedin.com/sometext
https://uk.linkedin.com/in/wiliam-ferraciolli-a9a29795
https://it.linkedin.com/hp/
https://cy.linkedin.com/hp/
https://www.linkedin.com/profile/view?id=AAIAABQnNlYBIx8EtS5T1RTUbxHQt5Ww&trk=nav_responsive_tab_profile
http://stackoverflow.com/questions/ask
google.com
http://uk.linkedin.com/in/someDodgeAddress
http://dodge.linkedin.com/in/someDodgeAddress
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)