import re
regex = re.compile(r"^https:\/\/[a-z]{2,3}\.linkedin\.com\/.*$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("https://www.linkedin.com/sometext\n"
"https://uk.linkedin.com/in/wiliam-ferraciolli-a9a29795\n"
"https://it.linkedin.com/hp/\n"
"https://cy.linkedin.com/hp/\n"
"https://www.linkedin.com/profile/view?id=AAIAABQnNlYBIx8EtS5T1RTUbxHQt5Ww&trk=nav_responsive_tab_profile\n\n\n\n"
"http://stackoverflow.com/questions/ask\n"
"google.com\n"
"http://uk.linkedin.com/in/someDodgeAddress\n"
"http://dodge.linkedin.com/in/someDodgeAddress")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")