const regex = /^https:\/\/[a-z]{2,3}\.linkedin\.com\/.*$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https:\\\/\\\/[a-z]{2,3}\\.linkedin\\.com\\\/.*$', 'gim')
const str = `https://www.linkedin.com/sometext
https://uk.linkedin.com/in/wiliam-ferraciolli-a9a29795
https://it.linkedin.com/hp/
https://cy.linkedin.com/hp/
https://www.linkedin.com/profile/view?id=AAIAABQnNlYBIx8EtS5T1RTUbxHQt5Ww&trk=nav_responsive_tab_profile
http://stackoverflow.com/questions/ask
google.com
http://uk.linkedin.com/in/someDodgeAddress
http://dodge.linkedin.com/in/someDodgeAddress`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}