#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^" # opening quote" & @CRLF & _
"(?:\\ # accept a literal backslash if it" & @CRLF & _
" (?: # if it's followed by" & @CRLF & _
" ["\\\/bfnrt] # one of the magic characters" & @CRLF & _
" | # or" & @CRLF & _
" u[\da-fA-F]{8} # a unicode character" & @CRLF & _
" )" & @CRLF & _
"| # or, if it's not" & @CRLF & _
" # a backslash-escaped character" & @CRLF & _
"[^"\\] # we accept anything that isn't" & @CRLF & _
" # a doublequote, backslash," & @CRLF & _
" # or possibly \r or \n" & @CRLF & _
")* # zero or more of these" & @CRLF & _
" # acceptable-content items" & @CRLF & _
""$ # the requisite closing quote"
Local $sString = "\uff009ea1" & @CRLF & _
"\t" & @CRLF & _
"\\" & @CRLF & _
"\b" & @CRLF & _
"\uff009ea1\t\\\b" & @CRLF & _
"\uff009ea1\\\b" & @CRLF & _
""Hello there, 123 !@&^#%! what???''"" & @CRLF & _
""Hello there 123 what"" & @CRLF & _
""Hello there, 123 !@&\t\\\b^#%! what???''"" & @CRLF & _
""Hello there \uff009ea1\t\\\b 123 what""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")