import Foundation
let pattern = ##"""
^" # opening quote
(?:\\ # accept a literal backslash if it
(?: # if it's followed by
["\\\/bfnrt] # one of the magic characters
| # or
u[\da-fA-F]{8} # a unicode character
)
| # or, if it's not
# a backslash-escaped character
[^"\\] # we accept anything that isn't
# a doublequote, backslash,
# or possibly \r or \n
)* # zero or more of these
# acceptable-content items
"$ # the requisite closing quote
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = ##"""
\uff009ea1
\t
\\
\b
\uff009ea1\t\\\b
\uff009ea1\\\b
"Hello there, 123 !@&^#%! what???''"
"Hello there 123 what"
"Hello there, 123 !@&\t\\\b^#%! what???''"
"Hello there \uff009ea1\t\\\b 123 what"
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)