const regex = /^" # opening quote
(?:\\ # accept a literal backslash if it
(?: # if it's followed by
["\\\/bfnrt] # one of the magic characters
| # or
u[\da-fA-F]{8} # a unicode character
)
| # or, if it's not
# a backslash-escaped character
[^"\\] # we accept anything that isn't
# a doublequote, backslash,
# or possibly \r or \n
)* # zero or more of these
# acceptable-content items
"$ # the requisite closing quote/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^" # opening quote
(?:\\\\ # accept a literal backslash if it
(?: # if it\'s followed by
["\\\\\\\/bfnrt] # one of the magic characters
| # or
u[\\da-fA-F]{8} # a unicode character
)
| # or, if it\'s not
# a backslash-escaped character
[^"\\\\] # we accept anything that isn\'t
# a doublequote, backslash,
# or possibly \\r or \\n
)* # zero or more of these
# acceptable-content items
"$ # the requisite closing quote', 'gm')
const str = `\\uff009ea1
\\t
\\\\
\\b
\\uff009ea1\\t\\\\\\b
\\uff009ea1\\\\\\b
"Hello there, 123 !@&^#%! what???''"
"Hello there 123 what"
"Hello there, 123 !@&\\t\\\\\\b^#%! what???''"
"Hello there \\uff009ea1\\t\\\\\\b 123 what"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}