# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^" # opening quote
(?:\\ # accept a literal backslash if it
(?: # if it's followed by
["\\\/bfnrt] # one of the magic characters
| # or
u[\da-fA-F]{8} # a unicode character
)
| # or, if it's not
# a backslash-escaped character
[^"\\] # we accept anything that isn't
# a doublequote, backslash,
# or possibly \r or \n
)* # zero or more of these
# acceptable-content items
"$ # the requisite closing quote
"""
test_str = ("\\uff009ea1\n"
"\\t\n"
"\\\\\n"
"\\b\n"
"\\uff009ea1\\t\\\\\\b\n"
"\\uff009ea1\\\\\\b\n"
"\"Hello there, 123 !@&^#%! what???''\"\n"
"\"Hello there 123 what\"\n"
"\"Hello there, 123 !@&\\t\\\\\\b^#%! what???''\"\n"
"\"Hello there \\uff009ea1\\t\\\\\\b 123 what\"")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.