import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\" # opening quote\n"
+ "(?:\\\\ # accept a literal backslash if it\n"
+ " (?: # if it's followed by\n"
+ " [\"\\\\\\/bfnrt] # one of the magic characters\n"
+ " | # or\n"
+ " u[\\da-fA-F]{8} # a unicode character\n"
+ " )\n"
+ "| # or, if it's not\n"
+ " # a backslash-escaped character\n"
+ "[^\"\\\\] # we accept anything that isn't\n"
+ " # a doublequote, backslash,\n"
+ " # or possibly \\r or \\n\n"
+ ")* # zero or more of these\n"
+ " # acceptable-content items\n"
+ "\"$ # the requisite closing quote";
final String string = "\\uff009ea1\n"
+ "\\t\n"
+ "\\\\\n"
+ "\\b\n"
+ "\\uff009ea1\\t\\\\\\b\n"
+ "\\uff009ea1\\\\\\b\n"
+ "\"Hello there, 123 !@&^#%! what???''\"\n"
+ "\"Hello there 123 what\"\n"
+ "\"Hello there, 123 !@&\\t\\\\\\b^#%! what???''\"\n"
+ "\"Hello there \\uff009ea1\\t\\\\\\b 123 what\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}