using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^"" # opening quote
(?:\\ # accept a literal backslash if it
(?: # if it's followed by
[""\\\/bfnrt] # one of the magic characters
| # or
u[\da-fA-F]{8} # a unicode character
)
| # or, if it's not
# a backslash-escaped character
[^""\\] # we accept anything that isn't
# a doublequote, backslash,
# or possibly \r or \n
)* # zero or more of these
# acceptable-content items
""$ # the requisite closing quote";
string input = @"\uff009ea1
\t
\\
\b
\uff009ea1\t\\\b
\uff009ea1\\\b
""Hello there, 123 !@&^#%! what???''""
""Hello there 123 what""
""Hello there, 123 !@&\t\\\b^#%! what???''""
""Hello there \uff009ea1\t\\\b 123 what""";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}