package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^" # opening quote
(?:\\ # accept a literal backslash if it
(?: # if it's followed by
["\\\/bfnrt] # one of the magic characters
| # or
u[\da-fA-F]{8} # a unicode character
)
| # or, if it's not
# a backslash-escaped character
[^"\\] # we accept anything that isn't
# a doublequote, backslash,
# or possibly \r or \n
)* # zero or more of these
# acceptable-content items
"$ # the requisite closing quote`)
var str = `\uff009ea1
\t
\\
\b
\uff009ea1\t\\\b
\uff009ea1\\\b
"Hello there, 123 !@&^#%! what???''"
"Hello there 123 what"
"Hello there, 123 !@&\t\\\b^#%! what???''"
"Hello there \uff009ea1\t\\\b 123 what"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}