using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\([^()]*\)[[:blank:]][[:blank:]]*)[^()]*\([^()]*\.([^()]*)\)";
string substitution = @"$1$2";
string input = @"TREE(abc/x73/APPLE) DEST(MYFILE.FILE1A)
TREE(abc/x74/APPLE) DEST(MYFILE88.FILE1A)
TREE(abc/x100/APPLE) DEST(MYFILE100.FILE1B)
TREE(abc/x61/APPLE) DEST(MYFILE1000.FILE1A)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}