import re
regex = re.compile(r"(\([^()]*\)[[:blank:]][[:blank:]]*)[^()]*\([^()]*\.([^()]*)\)", flags=re.MULTILINE)
test_str = ("TREE(abc/x73/APPLE) DEST(MYFILE.FILE1A) \n"
"TREE(abc/x74/APPLE) DEST(MYFILE88.FILE1A) \n"
"TREE(abc/x100/APPLE) DEST(MYFILE100.FILE1B) \n"
"TREE(abc/x61/APPLE) DEST(MYFILE1000.FILE1A)")
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)