# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[-_]/\n/g;t' <<< "section_d1_2010-07-01_08_00.txt"