import Foundation
let pattern = #"[-_]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"section_d1_2010-07-01_08_00.txt"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)